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UPOZORENJE 

Prilikom korištenja ovog priručnika i SCRAPY KIT-a, molimo da 

obratite pozornost na sljedeće točke upozorenja: 

1. SCRAPY KIT sadrži mnogo sitnih dijelova. Gutanje ili 

nepravilno rukovanje može uzrokovati ozbiljne infekcije i 

smrt. U slučaju nesreće odmah potražite liječničku 

pomoć. 

2. Strogo zabranjena uporaba proizvoda i njegovih dijelova 

u blizini izlaza za izmjeničnu struju ili drugih strujnih 

krugova u slučaju mogućeg rizika od strujnog udara. 

3. Strogo zabranjena uporaba ovog proizvoda u blizini 

tekućina ili vatre. 

4. Vodljive materijale držati podalje od ovog proizvoda.  

5. Ne dopuštajte djeci mlađoj od 3 godine da koriste ovaj 

proizvod bez nadzora odrasle osobe. Molimo da ovaj 

proizvod držite na mjestu koje nije dostupno djeci mlađoj 

od 3 godine. 

6. Ne skladištiti niti upotrebljavati ovaj proizvod u 

ekstremnim uvjetima kao što su ekstremna hladnoća ili 

vrućina, visoka vlažnost, pod izravnom sunčevom 

svjetlošću itd.   

7. Ne zaboravite prekinuti strujni krug kada nije u upotrebi. 

8. Neki dijelovi ovog proizvoda mogu postati topli na dodir 

kada se upotrebljavaju u određenim dizajnima strujnih 

krugova, što je uobičajeno. 

9. Nepravilna upotreba može uzrokovati pregrijavanje.  

10. Korištenje komponenta koje nisu u skladu sa 

specifikacijom može uzrokovati oštećenje proizvoda.  
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Uvod 

„SCRAPY KIT“, komplet je izrađen na temelju upotrebe 

mikrokontrolera Raspberry Pi Pico. “SCRAPY komplet 

uspostavlja se u okviru projekta sufinanciranog od Erasmus+ 

programa. 

Novi trend edukacije na daljinu, koja je posljedica pandemije 

bolesti COVID-19, predstavlja jaz u poučavanju i prakticiranju 

aktivnosti fizičkog računalstva do učenika koji su izloženi riziku 

od slabih rezultata u takvim STEM predmetima. 

Cilj kompleta je da podupire i promiče praktično učenje u 

računalstvu i programiranju u slučajevima poučavanja na daljinu 

i u učionicama. Komplet pruža kombinaciju fizičkih računalnih 

načela i programiranja s hardverom i softverom, što dovodi do 

inovativnog iskustva učenja.  

Opseg ovog priručnika je:  

- Obavijestiti vas o ključnim komponentama i upotrebi 

glavnih elektroničkih elemenata.  

- Voditi vas korak po korak kako biste učinkovito sastavili 

komplet, uzimajući u obzir odgovarajuće mjere opreza.  

- Pružiti upute za uporabu komponenta i vezu s Pico 

mikrokontrolerom. 

- Pružiti upute s funkcijama i opsegom svake elektroničke 

komponente. 

 

Uživajte u čitanju i zabavite se kroz praktičnu 

praksu i eksperimentiranje sa „SCRAPY“ 

kompletom 
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Uključeno u „SCRAPY“ kompletu 

  

  

 

 

 

GPIO Tiskana pločica 
Raspberry Pi Pico 

(2kom.) 
 

 

MB-102 Napajački modul 
(1kom.) 

 

 

Bijela breadboard testna 
ploča 830 rupica(1kom.) 

+ 400 rupica (1kom.) 
 

 

Tipkalo (1kom.) i 
Poklopac za gumb 

(1kom.) 
 

 

Zujalica (1kom.) 
 

 

Otpornik 220 Ohm 
(5kom.) + 1000 Ohm 

(5kom.) 
 
 

 
 
 

LDR fotootpornik 
(1kom.)  

 
 

 

100uF električni 
kondenzator (1kom.)  

 

 

LED diode 3mm Plava 
(1kom.), Zelena (1kom.), 

Crvena(1kom.) Žuta 
(1kom.) 

 

 

RGB LED 5mm (1kom.) 

 

 

SG90 servo motor 
(1kom.) 

 
 

 
 
 

OLED I2C ICC (1kom.) 
 

 

HC-SR04 ultrazvučni 
senzor (1kom.) 

 

 

PIR Detektor pokreta HC-
SR501 (1kom.) 

 

 

DHT11 Senzor digitalne 
temperature i vlažnosti 

(1kom.) 
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Senzor kapi kiše (1kom.) 

 

 

Rotacijski potenciometar 
linearni B1k Ohm 

(1kom.) 
 

 

SW-420 senzor vibracija 

(1pc) 
 
 

 

Detektor plamena 
(1kom.)  

 
 

 
 

Senzor otkrivanja zvuka 
visoke osjetljivosti 

(1kom.) 
 

 
 

Higrometar tla / detektor 
vlage tla (1 kom.) 

 

 

Modul infracrveni IR 
senzora KY-032 (1kom.)  

 

 
 

“Joystick” modul 
(1kom.)  

 

 

USB na micro-USB kabel 
1m (1kom.) 

 

 
 
 

6 x AA 1.5V baterija 
(1kom.) + držač (1kom.) 

 

 

Premosni kabel (6 kom.) 

 

 

Plastični vijci (10 kom.) , 

plastične matice (6 
kom.), plastični stupići 

(10 kom.) 
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Objašnjenje sastavnih dijelova 

1. Što je breadboard testna ploča? 

 

Breadboard testna ploča je plastična ploča sa sitnim rupama koje 

omogućavaju jednostavno umetanje elektroničkih komponenti 

(prijenosnika, otpornika, čipova itd.) kako bi se izradio prototip 

elektroničkog strujnog kruga. Unutrašnjost se sastoji od nizova 

sitnih metalnih kopči za držanje vodova koje treba spojiti. 

Većina breadboard testnih ploča ima nizove brojeva, slova te 

plus/minus znakova koji su napisani na njima. Svrha oznaka je 

da vam pomognu locirati određene rupe na breadboard testnoj 

ploči kako biste mogli slijediti upute pri izgradnji strujnog kruga.  

Duge trake na dvije strane breadboard testne ploče su obično 

označene crvenom i plavom bojom ili crvenom i crnom bojom te 

znakovima plus (+) i minus (-). Ti se redovi nazivaju „busovima“ 

ili vodovima i obično se upotrebljavaju za napajanje strujnog 

kruga električnom energijom kad je priključen na napajanje 

(baterija ili vanjski izvor napajanja).  

Pozitivan “bus” označen je crvenom bojom, ima znak plus (+) i 

osigurava struju.  

Negativni “bus” je označen plavom ili crnom bojom, ima znak 

minus (-) i osigurava uzemljenje. 
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Prednosti uporabe breadboard testne ploče: 

• Olakšava brzu provjeru jednostavnih i složenih strujnih 

krugova te laku provjeru strujnih krugova u njihovoj 

početnoj fazi.  

• Lako prilagodljiva. 

• Fleksibilna. 

• Nije potrebno bušenje rupa. 

• Nije potrebno lemljenje.  

• Jednostavno otklanjanje neispravnosti strujnih krugova i 

programa.  

2. Što je otpornik? 

 

Otpornik je malo pakiranje otpora. Njegovom upotrebom u 

strujnom krugu, struja se smanjuje za točno određen iznos. Za 

određivanje otpora otpornika postoji uzorak obojenih traka.  

 

(Image credit: Future Owns) available at https://www.tomshardware.com/how-

to/resistor-color-codes  

https://www.tomshardware.com/how-to/resistor-color-codes
https://www.tomshardware.com/how-to/resistor-color-codes
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Česte boje kodova otpornika i njihova uporaba: 

Vrsta 
otpornika 

Boja koda s 4 
vrpce  

Boja koda s 5 
vrpca 

Česta 
uporaba 

220Ohm Crvena-
Crvena-
Smeđa-Zlatna 

Crvena-
Crvena-Crna-
Crna-Zlatna 

Zaštita LED 
svjetlosti 

1000 Ohm 
(1Kiloohm) 

Smeđa-Crna-
Crvena-Zlatna 

Smeđa-Crna-
Crna-Smeđa-
Zlatna 

Zaštita LED 
svjetlosti, 
Razdjelnik 
napora 

Otpornici nemaju polarnost kako bi se mogli koristiti u bilo kojoj 

orijentaciji u strujnom krugu. Međutim, kako bismo utvrdili točne 

vrijednosti kodova u boji, moramo razumjeti značenje obojenih 

traka na otporniku. 

Na tipičnom amaterskom otporniku s 4 vrpce, u skupini se nalaze 

tri boje. Ovo su prva i druga značajna brojka te množitelj. 

Konačna vrpca je tolerancija otpornika, ona služi kao granica 

pogreške. Za većinu amatera, tolerancija od 5% (zlatna) je 

savršena i uobičajena.  

Otpornik 200 Ohm (4 vrpce)  

 

(Image credit: Future) available at https://www.tomshardware.com/how-

to/resistor-color-codes  

https://www.tomshardware.com/how-to/resistor-color-codes
https://www.tomshardware.com/how-to/resistor-color-codes
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1. Prva je značajna brojka crvena, a upotrebom dekodera 

možemo vidjeti da njena vrijednost iznosi 2. 

2. Druga značajna brojka je također crvena, što nam daje 

22.  

3. Množitelj je smeđe boje te se dekodira u 10. Ako 

pomnožimo 22 s 10, dobivamo 220.  

4. Zadnja vrpca, tolerancija, je zlatna. Zlatna vrpca ima 

vrijednost 5%, što znači da možemo prihvatiti otpor koji 

odstupa 5%. 

Za izrađivače kojima je potrebna veća preciznost postoje i 

otpornici s pet vrpca koji imaju i treću značajnu brojku. Ta 

dodatna brojka pruža jasnoću koja može biti ključna u strujnim 

krugovima koji su osjetljivi na otpornost, primjerice u 

znanstvenim i inženjerskim instrumentima.  

Otpornik 1000 Ohm (4 vrpce) 

 

(Image credit: Tom’s Hardware) available at 

https://www.tomshardware.com/how-to/resistor-color-codes  

1. Prva linija je smeđa, a koristeći dekoder može vidjeti da 

je njena vrijednost 1.  

2. Druga linija je crna, što nam daje 10. 

https://www.tomshardware.com/how-to/resistor-color-codes
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3. Množitelj je crvene boje te se dekodira u 10. Ako 

pomnožimo 10 s 100, dobivamo 1000. 

4. Zadnja vrpca, tolerancija, je zlatna. Zlatna vrpca ima 

vrijednost 5%, što znači da možemo prihvatiti otpor koji 

odstupa 5%. 

3. Što je električni kondenzator? 

 

Električni kondenzator je naprava koja pohranjuje električnu 

energiju u električnom polju. Riječ je o pasivnoj elektroničkoj 

komponenti sastavljenoj od dva terminala. Sastoji se od dva 

odvojena električna vodiča. Prostor između tih vodiča može biti 

ispunjen vakuumom ili dielektričnim izolacijskim materijalom. 

(Wikipedia) 

Kondenzator od 100uF je elektrolitski kondenzator za odvajanje. 

Ovi kondenzatori su izvrsni prigušivači prenapona i uporabom  

jednog između energije i uzemljenja strujnog kruga osigurava se 

nesmetani dovod energije.  

4. Što je dioda? 

 

Dioda je dvoterminalna elektronička komponenta koja provodi 

struju prvenstveno u jednom smjeru (asimetrična vodljivost); ima 

nizak (idealno nikakav) otpor u jednom smjeru i visok (idealno 

beskonačan) otpor u drugom.  

Najčešća je funkcija diode omogućiti prolaz električne struje u 

jednom smjeru (smjer naprijed) dok ga blokira u drugom smjeru 

(obrnuti smjer). Kao takva, dioda se može smatrati električnom 
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verzijom nepovratnog ventila. Ovo jednosmjerno ponašanje 

naziva se rektifikacijom i upotrebljava se za pretvaranje 

izmjenične struje (ac) u istosmjernu struju (dc). Kao rektifikatori, 

diode se mogu koristiti za zadatke poput izvlačenja modulacije iz 

radio signala u radijskim prijamnicima. (Wikipedia 

https://en.wikipedia.org/wiki/Diode)  

5. Što su premosni kabovi? 

 

 

Premosni kablovi su, jednostavno rečeno, kablovi koji imaju 

priključke na svakom kraju što im omogućuje da se koriste za 

spajanje dviju točaka bez lemljenja. Premosni kablovi su tipično 

korišteni s breadboard testnim pločama i drugim alatima za 

izradu prototipa kako bi se prema potrebi olakšala izmjena 

strujnih krugova. Razlika u boji kablova može služiti kao indikator 

različitih vrsta priključaka, kao što su uzemljenje ili energija.  

Premosni kabel obično dolaze u tri verzije: muški, muški-prema-

ženskom i ženski. Razlikuju se po krajnjoj točki kabla. „Muški“ 

krajevi kablova imaju iglu te se mogu spojiti u nešto, dok „ženski“ 

krajevi nemaju iglu i koriste se da se spoje u nešto. Muški kablovi 

su najčešći. Pri povezivanju dva priključaka na breadboard 

testnu ploču, većinom nam je potrebna muška žica. 

(https://blog.sparkfuneducation.com/what-is-jumper-wire) 

https://en.wikipedia.org/wiki/Diode
https://blog.sparkfuneducation.com/what-is-jumper-wire
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Priprema projekta 

1. Pročitaj prije korištenja 

OBAVIJEST: Budući da sljedeći eksperimenti svi koriste strujni 

krug, pogrešno spajanje ili kratki spoj mogu oštetiti vašu Pico 

razvojnu pločicu. Molimo da prije priključenja napajanja uvijek 

ponovno provjerite strujni krug. 

2. Raspberry Pi Pico 

Ovo je Raspberry Pi Pico: 

 

Priključite micro-USB kabel u otvor na lijevoj strani ploče. 
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3. Instalirajte Thonny IDE 

Posjetite web-stranicu https://thonny.org i odaberite odgovarajući 

operativni sustav. Slijedite upute za dovršetak instalacije.  

 

U ovom priručniku, sve upute su programirane u Windows 10, 

koristeći Raspberry Pi Pico i odgovarajući firmware. 

Nakon završetka instalacije, otvorite Thonny na svojem računalu. 

 

 

4. Instalacija firmwarea 

https://thonny.org/
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Raspberry Pi Pico može se programirati pomoću varijante 

Pythona koja se zove MicroPython. Da biste mogli koristiti 

MicroPhyton na Pico-u, prvo morate instalirati njegov firmware. 

Korak 1: Pronađite BOOTSEL tipku na svojem Raspberry Pi Pico 

uređaju. 

 

Korak 2: Pritisnite gumb BOOTSEL i držite ga dok drugi kraj 

micro-USB kabela povezujete sa svojim računalom. 

Korak 3: U donjem desnom kutu Thonnya vidjet ćete verziju 

Phytona koju trenutno koristite. 

 

Kliknite na Python verziju i odaberite MicroPhyton (Rapsberry Pi 

Pico) 

 

Ako ne vidite ovu opciju, provjerite ako je kabel ispravno spojen 

na Pico i/ili na vaše računalo. 
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Korak 4: Pojavit će se dijaloški okvir u kojem će se od vas tražiti 

da instalirate najnoviju firmware verziju Pico-a. Kliknite na 

„Install“ kako biste kopirali firmware u vaš Pico. 

 

Korak 5: Pričekajte da se instalacija dovrši i kliknite „Close“. 

 

Ne morate ponavljati ovaj postupak svaki put kada spajate 

Raspberry Pi Pico na svoje računalo, stoga ga sljedeći put samo 

priključite i možete krenuti s radom.  
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5. Uvod u MicroPyhton programiranje 

Sada ćete upotrijebiti Thonny IDE kako biste pokrenuli 

jednostavni Phyton kod te kako biste se upoznali s Thonny’s 

Shell i MicroPhytonom. 

Prvo se pobrinite da je vaš Raspberry Pi Pico spojen na vaše 

računalo te da ste odabrali MicroPhyton funkciju kako je 

objašnjeno u prethodnom odjeljku. 

Shell okvir na dnu Thonny uređivača trebao bi izgledati ovako: 

 

Thonny je spreman komunicirati s vašim Pico koristeći REPL 

(čitaj-procijeni-ispiši petlja) framework, koji vam omogućuje da 

napišete kod direktno u Shell i dobijete output. 

Upišite sljedeću naredbu: 

print(“Hello!”) 

Zatim pritisnite tipku Enter i vidjet ćete sljedeći output. 

 

MicroPython  vam omogućuje dodavanje modula specifičnih za 

hardver kao što su machine, koje možete koristiti u svojem 

programu Pico. U sljedećem primjeru upotrebljavat ćete  

machine modul kako biste uključili LED diode Pico-a. 

Napišite sljedeći kod u Thonny’s Shell: 

from machine import Pin 

led = Pin(25, Pin.OUT) 
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led.value(1) 

 

Pritisnite Enter tipku i LED diode Pico-a će se odmah uključiti. 

 

Kako biste isključili LED diode, upišite sljedeći kod: 

led.value(0) 

  

U ostatku ovog odjeljka, napisati ćete svoj prvi „pravi“ program 

kojim će LED dioda treptati svaki put kada pokrenete svoj 

program. 

Thonny Shell koristan je za izvođenje brzih naredbi i osigurava 

da sve radi ispravno. Međutim, dulji programi trebali bi se 

spremiti u .py datoteku. Koristeći Thonny, možete spremiti 

programe direktno u Raspberry Pi Pico i zatim ih pokrenuti. 

Otvorite Thonny Python i na glavnom oknu uređivača upišite 

sljedeći kod: 

from machine import Pin 
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led = Pin(25, Pin.OUT) 

led.toggle() 

Sada, spremite svoj program klikom na „Save“ na gornjoj lijevoj 

strani ili pritisnite Ctrl+S na vašoj tipkovnici. 

 

Thonny će vas upitati gdje želite spremiti vaš program. Odaberite 

Raspberry Pi Pico. Spremite datoteku kao blink.py i kliknite OK. 

Uvijek morate dodati .py proširenje tako da Thonny prepozna 

datoteku kao Python datoteku. 

 

Svaki put kada pritisnete na „Play“, trebali biste vidjeti LED diodu 

kako se uključuje i isključuje. 
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Da vaš kod odvedete jedan korak dalje, možete učiniti da LED 

diode trepću određenom brzinom. 

Upišite sljedeći kod i spremite program koristeći isto ime kako je 

prethodno navedeno. 

from machine import Pin 

from time import sleep 

led = Pin(25, Pin.OUT) 

while True: 

 led.toggle() 

 sleep(1) 

Sada, kada pokrenete program, LED dioda će treptati svaku 

sekundu dok ne zaustavimo program. Da zaustavite program 

možete kliknuti „STOP“ ili pritisnuti Ctrl+C na vašoj tipkovnici. 

U budućim uputama, naučit ćemo kako dodati i kontrolirati ostalu 

elektroniku i senzore kako bismo mogli stvoriti programe koji 

mogu međusobno komunicirati. 

Montaža kompleta 

SCRAPY komplet sastoji se od sljedećih komponenti: 

• 1x 3D printani komad 

• 1 x komad pleksiglasa 

• 1 x Raspberry Pi Pico 

• 1 x GPIO tiskana pločica 

• 1 x Breadboard testna ploča (830 rupica) 

• 10 x Plastičnih vijaka 

• 6 x 12mm plastičnih stupića 

• 4 x 6mm plastičnih stupića 

• 6 x plastičnih matica 
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Postupak sastavljanja je jednostavan i može se dovršiti u 6 

koraka: 

Korak 1: Montirajte plastične stupiće veličine 6 x 12mm koristeći 

6 plastičnih matica na komad pleksiglasa. 
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Korak 2: Na 3D isprintani komad, postavite 4 x 6mm plastične 

stupiće na “GPIO Breakout Board” dio. 

 

 

Korak 3: Montirajte GPIO tiskanu pločicu na 4 stupića koristeći 4 

plastična vijka. 
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Korak 4: Montirajte 3D printani komad s komadom pleksiglasa 

tako da stavite 6 plastičnih vijaka na 6 plastičnih stupića koje ste 

montirali u prvom koraku. 
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Korak 5: Odlijepite zaštitnu vrpcu koja se nalazi ispod 

breadboard testne ploče s 830 rupica i postavite ju na 

“Breadboard” dio kompleta. Molimo pobrinite se da je pozitivna 

(+) strana ujedno i gornja strana, kako pokazuje sljedeća slika. 

 

Korak 6: Postavite Raspberry Pi Pico na GPIO tiskanu pločicu i 

pritisnite sve dok sve GPIO igle nisu ispravno umetnute. 

Pobrinite se da je micro-USB utor na gornjoj strani kako slika 

pokazuje. 
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Osnovne upute 

0. “Pozdrav „SCRAPY“ ljudi!” 

U ovoj osnovnoj lekciji, naučit ćemo kako printati jednostavnu 

poruku u Thonny-u koristeći Python programiranje. 

Print() funkcija 

1. Uđite u Thonny uređivač, napišite sljedeći kod i pritisnite 

„play“. Thonny će vas upitati da prvo spremite program. 

Spremite ga pod nazivom hello.py. 

 

2. Provjerite shell prozor. 

 

3. Dobar posao! Upravo ste kreirali vaš prvi Python 

program. 
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Print funkcija je ugrađena Python funkcija koja nam dopušta da 

printamo tekst u shell. Također može uzeti parametre. Kreirajte 

novi program i kopirajte sljedeći kod, zatim pritisnite „play“ i 

gledajte kako se tekst pojavljuje u shellu.  

 

Kao što možete vidjeti u shell prozoru, svaka print funkcija printa 

tekst u zasebnom retku. Međutim, ako koristite “\n” (znak novog 

retka) možete promijeniti redak u istoj ispisnoj izjavi. 

 

Vježba 

Iskoristite print funkciju da printate 3 zasebna retka „Goodbye 

SCRAPY people!“ koristeći samo jednu ispisnu izjavu. 
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4. Kontrola LED diode 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati LED svjetlo. 

Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom  

led.py. Zatim je vrijeme da spojite elektroniku i napišite svoj 

program. Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 2 x Muški premosni kabel  

• 1 x Micro-USB kabel • 1 x 220 Ohm otpornik 

• 1 x LED (bilo koje boje)  

 

Dijagram ožičenja  

 

– spojite duži kraj (+) LED diode na 220Ohm otpornik 

– spojite otpornik na GPIO5 (crveni kabel) 

– spojite kraći (-) LED diode na GND iglu 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako strujni krug izgleda koristeći priloženi hardver: 
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5. Tipkalo 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati tipkalo. Otvorite 

Thonny Python, zatim idite u File → Save as…, odaberite 

Raspberry Pi Pico, i spremite datoteku pod imenom button.py. 

Zatim je vrijeme da spojite elektroniku i napišite svoj program. 

Molimo pratite instrukcije u nastavku. 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x 220 Ohm otpornik 

• 1 x Tipkalo (bilo koje boje) • 1 x Poklopac za gumb 

Dijagram ožičenja  

 

– spojite gornju lijevu stranu tipkala na 3v3 iglu (crveni kabel) 

– spojite donju desnu stranu tipkala na GPIO5 (žuti kabel)  

– spojite GND iglu na (-) vod (crni kabel) 

– spojite 220 Ohm otpornik na (-) vod i desnu gornju stranu 

tipkala  
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako strujni krug izgleda koristeći priloženi hardver: 
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6. Zujalica 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati zujalicu. Otvorite 

Thonny Python, zatim idite u File → Save as…, odaberite 

Raspberry Pi Pico, i spremite datoteku pod imenom buzzer.py. 

Zatim je vrijeme da spojite elektroniku i napišite svoj program. 

Molimo pratite instrukcije u nastavku. 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 2 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x Zujalica 

Dijagram ožičenja  

 

– spojite duži kraj (+) zujalice na GPIO5 iglu 

– spojite kraći kraj (-) zujalice na GND iglu 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako strujni krug izgleda koristeći priloženi hardver: 
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7. Potenciometar 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati potenciometar. 

Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

pot.py. Zatim je vrijeme da spojite elektroniku i napišite svoj 

program. Molimo pratite instrukcije u nastavku. 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x Potenciometar  

Dijagram ožičenja  

 

– crni kabel bi trebao biti spojen na GND (Igla 3) iglu 

– žuti kabel bi trebao biti spojen na GPIO6 iglu 

– crveni kabel bi trebao biti spojen na 3V3 iglu 

– pomaknite potenciometar ulijevo tako da bude isključen 

  



 
2021-1-FR01-KA220-SCH-000031617 

 

 

 
 

33 

Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako strujni krug izgleda koristeći priloženi hardver: 
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8. RGB LED 

Description 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati RGB LED 

svjetla. Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

rgb.py. Zatim je vrijeme da spojite elektroniku i napišite svoj 

program. Molimo pratite instrukcije u nastavku. 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 4 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x RGB LED modul 

Dijagram ožičenja  

 

– crveni kabel bi trebao biti spojen na GPIO2 

– zeleni kabel bi trebao biti spojen na GPIO3 

– plavi kabel bi trebao biti spojen na GPIO4 

– nije potrebna GND konekcija 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako strujni krug izgleda koristeći priloženi hardver: 
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Napredne upute 

Prije nego započnemo s ovim i sljedećim odjeljkom, moramo 

napraviti nekoliko modifikacija na našem SCRAPY kompletu. To 

uključuje nekoliko dodatnih komponenti i njihovu povezanost. 

Komponente 

• 1 x 6-AA baterija • 1 x MB-102 modul napajanja 

• 4 x Muški premosni kabel  

Molimo da slijedite shemu za povezivanje novih komponenti:  

 

Strujni krug 

 

– ova će se instalacija koristiti za preostale lekcije 

– priključci na gornjoj strani: VSYS 5V ((+) crvena) i GND ((-) 

crna) 
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– priključci na donjoj strani: 3V3 ((+) crvena) i GND ((-) crna) 

9. LDR Fotootpornik 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati LDR 

fotootpornik. Otvorite Thonny Python, zatim idite u File → Save 

as…, odaberite Raspberry Pi Pico, i spremite datoteku pod 

imenom ldr.py. Zatim je vrijeme da spojite elektroniku i napišite 

svoj program. Molimo pratite instrukcije u nastavku. 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x LDR fotootpornik 

• 1 x 220Ohm otpornik  

Dijagram ožičenja  

 

– lijeva strana LDR fotootpornika je spojena na 3V vod ((+) 

crvena) 

– desna strana LDR fotootpornika je spojena na 220 Ohm 

otpornik i GPIO26 ADC (žuti kabel) iglu 

– desna strana otpornika je spojena na GND vod ((-) crna) 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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10.  Servo motor 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati servo motor. 

Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

servo.py. Zatim je vrijeme da spojite elektroniku i napišite svoj 

program. Molimo pratite instrukcije u nastavku. 

Potreban materijal) 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x SG-90 servo motor 

Dijagram ožičenja  

 

– crveni kabel je spojen na 5V vod (+) 

– crni/smeđi kabel je spojen na GND vod (-) 

– narančasti kabel je spojen na GPIO28 ADC iglu 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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11. OLED I2C SSD1306 zaslon 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati I2C ICC OLED 

zaslon. Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

oled.py. Zatim je vrijeme da spojite elektroniku i napišite svoj 

program. Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 4 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x OLED I2C SSD1306 zaslon 

 

Dijagram ožičenja  

 

– crveni kabel je spojen na 3v3 vod (+) 

– crni kabel je spojen na GND vod (-) 

–narančasti kabel je spojen na GPIO17 I2C0 SCL iglu 

– plavi kabel je spojen na GPIO26 I2C0 SDA iglu 
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Kod 

Prije početka programiranja OLED zaslona moramo dodati 

SSD1306 paket u naš RPi Pico. Kako biste to učinili, molimo 

slijedite sljedeće korake: 

1. Otvorite Thonny i idite u Tools → Manage packages… 

 

2. Na prozoru upravljanja paketa, upišite SSD1306 i kliknite 

Search. 
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3. Nakon što je pretraga gotova, kliknite na micropython-

ssd1306. 

 

4. Na sljedećem prozoru, kliknite Install. 

 

5. Pričekajte instalaciju paketa, i kliknite close. 

Sada smo spremni nastaviti s programiranjem OLED zaslona.   
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MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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12. „Joystick“ modul 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati „joystick“ modul. 

Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

joystick.py. Zatim je vrijeme da spojite elektroniku i napišite 

svoj program. Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 5 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x „Joystick“ modul 

 

Dijagram ožičenja  

 

– +5V (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 
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– VRx (plavi kabel) je spojen na GPIO27 ADC1 iglu 

– VRy (narančasti kabel) je spojen na GPIO26 ADC0 iglu 

– SW (zeleni) kabel je spojen na GPIO22 iglu 

Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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Lekcije sa senzorima 

13. Senzor kapi kiše 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati senzor kapi kiše. 

Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

raindrop.py. Zatim je vrijeme da spojite elektroniku i napišite 

svoj program. Molimo pratite instrukcije u nastavku. 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x Senzor kapi kiše 

Dijagram ožičenja  

 

– 3v3V (crveni kabel) je spojen na 3v3V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 
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– DO (narančasti kabel) je spojen na GPIO17 iglu 

Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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14. HC-SR04 Ultrazvučni senzor 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati HC-SR04 

ultrazvučni senzor. Otvorite Thonny Python, zatim idite u File → 

Save as…, odaberite Raspberry Pi Pico, i spremite datoteku pod 

imenom ultrasonic.py. Zatim je vrijeme da spojite 

elektroniku i napišite svoj program. Molimo pratite instrukcije u 

nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x HC-SR04 Ultrazvučni senzor 

Dijagram ožičenja  

 

– VCC (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 

– TRIG (narančasti kabel) je spojen na GPIO2 iglu 

– ECHO (zeleni kabel) je spojen na GPIO3 iglu 

Kod 
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Za upotrebu HC-SR04 ultrazvučnog senzora možemo razviti 

vlastiti program, ili koristiti jednu od dostupnih programskih 

biblioteka na internetu s primjerice Githuba. Ako odlučite preuzeti 

hcsr04.py programsku biblioteku, trebali biste je spremiti u svoj 

Pico-u pod istim imenom.  

MicroPython kod koristeći postojeću programsku biblioteku: 

 

https://github.com/rsc1975/micropython-hcsr04/blob/master/hcsr04.py
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MicroPython kod bez postojeće programske biblioteke: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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15. PIR Detektor pokreta 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati PIR detektor 

pokreta. Otvorite Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

motion.py. Zatim je vrijeme da spojite elektroniku i napišite svoj 

program. Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Full size breadboard • 3 x Muški premosni kabel 

• 1 x Micro-USB cable • 1 x PIR detektor pokreta 

Dijagram ožičenja  

 

– VCC (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 

– OUT (narančasti kabel) je spojen na GPIO21 iglu 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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16. DHT11 senzor 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati DHT11 senzor 

digitalne temperature i vlažnosti. Thonny Python, zatim idite u 

File → Save as…, odaberite Raspberry Pi Pico, i spremite 

datoteku pod imenom dht11.py. Zatim je vrijeme da spojite 

elektroniku i napišite svoj program. Molimo pratite instrukcije u 

nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x DHT11 senzor temperature 

Dijagram ožičenja 

 

– VCC (red cable) is connected to 3v3 rail (+) 

– GND (black cable) is connected to GND rail (-) 

– S (green cable) is connected to GPIO21 pin 

  



 
2021-1-FR01-KA220-SCH-000031617 

 

 

 
 

55 

Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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17. SW-420 Senzor vibracije 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati SW-420 senzor 

vibracije. Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

vibration.py. Zatim je vrijeme da spojite elektroniku i napišite 

svoj program. Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x SW-420 senzor vibracije 

Dijagram ožičenja 

 

– VCC (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 

– DO (zeleni kabel) je spojen na GPIO21 iglu 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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18.  Detektor plamena  

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati KY-026 detektor 

plamena. Thonny Python, zatim idite u File → Save as…, 

odaberite Raspberry Pi Pico, i spremite datoteku pod imenom 

flame.py. Zatim je vrijeme da spojite elektroniku i napišite svoj 

program. Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x KY-026 detektor plamena 

Dijagram ožičenja 

 

– VCC (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 

– DO (zeleni kabel) je spojen na GPIO21 iglu 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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19.  Senzor za otkrivanje zvuka 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati KY-037 senzor 

za otkrivanje zvuka. Thonny Python, zatim idite u File → Save 

as…, odaberite Raspberry Pi Pico, i spremite datoteku pod 

imenom sound.py. Zatim je vrijeme da spojite elektroniku i 

napišite svoj program. Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x KY-037 senzor za otkrivanje 
zvuka 

Dijagram ožičenja 

 

– VCC (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 

– DO/OUT (zeleni kabel) je spojen na GPIO21 iglu 
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Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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20. Detektor vlage tla 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati detektor vlage 

tla. Thonny Python, zatim idite u File → Save as…, odaberite 

Raspberry Pi Pico, i spremite datoteku pod imenom soil.py. 

Zatim je vrijeme da spojite elektroniku i napišite svoj program. 

Molimo pratite instrukcije u nastavku. 

 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x Detektor vlage tla 

Dijagram ožičenja 

 

– VCC (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 
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– DO/OUT (zeleni kabel) je spojen na GPIO21 iglu 

Kod 

MicroPython kod za lekciju: 

 

Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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21. Infracrveni IR senzor 

Opis 

U ovoj lekciji naučit ćete kako spojiti i kontrolirati infracrveni IR 

senzor. Thonny Python, zatim idite u File → Save as…, odaberite 

Raspberry Pi Pico, i spremite datoteku pod imenom ir.py. 

Zatim je vrijeme da spojite elektroniku i napišite svoj program. 

Molimo pratite instrukcije u nastavku. 

Potreban materijal 

• 1 x Raspberry Pi Pico • 1 x Pico komplet za breadboard 
testnu ploču 

• 1 x Breadboard testna ploča 
pune veličine 

• 3 x Muški premosni kabel 

• 1 x Micro-USB kabel • 1 x Infracrveni IR senzor 

Dijagram ožičenja 

 

– VCC (crveni kabel) je spojen na 5V vod (+) 

– GND (crni kabel) je spojen na GND vod (-) 

– OUT (zeleni kabel) je spojen na GPIO21 iglu 

Kod 

MicroPython kod za lekciju: 
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Primjer 

Slika kako lekcija izgleda koristeći priloženi hardver: 
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DODATAK: MicroPython tablica sažetka 

Digitalni izlaz 

Pozivanje na vrijednost 
pina 

from machine import Pin  

Inicijalizacija digitalnog 
izlaznog objekta 

led = Pin(pin_value, Pin.OUT) pin_value od 0 do 40 

Otvori digitalni izlaz 
(3.3V izlaz) 

led.value(1) UKLJUČENO 

Zatvori digitalni izlaz 
(0V izlaz) 

led.value(0) ISKLJUČENO 

 

Digitalni ulaz 

Pozivanje na vrijednost 
pina 

from machine import Pin  

Inicijalizacija digitalnog 
izlaznog objekta 

button = Pin(pin_value, Pin.IN) pin_value od 0 do 40 

button = Pin(pin_value), 

Pin.IN, Pin.PULL_UP) 
Aktivacija PULL UP otpora 

button = Pin(pin_value), 

Pin.IN, Pin.PULL_DOWN) 

Aktivacija PULL DOWN 
otpora 

Očitavanje unosa value = button.value(1) 

Povratna vrijednost može 
biti 0 ako je igla na 0V, ili 1 
ako je igla na 3.3V 

 

Analogni izlaz (Modulacija širine pulsa - PWM) 

Pozivanje na vrijednost 
PWM-a 

from machine import PWM  

Inicijalizacija analognog 
izlaznog objekta 

led = PWM(Pin(pin_value), 

frequency) 

pin_value od 0 do 40 

frequency u HZ, od 0 do 

78125 

Očitavanje unosa led.duty(duty_cycle) 
duty_cycle od 0 do 1023 

(0V izlaz do 3.3V izlaz) 
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Digitalni Ulaz 

Pozivanje na vrijednost 
ADC-a 

from machine import ADC  

Inicijalizacija analognog 
ulaznog objekta 

pot = ADC(Pin(pin_value)) 

pin_value može biti GPIO26, 

GPIO27 and GPIO28 

 

Deklaracija pri kojem će 
naponu ulaz dati 
najveću vrijednost (u 
ESP32 obično 3.3V) 

pot.atten(ADC.ATTN_11DB) 

ADC.ATTN_0DB: napon punog 
raspona: 1.2 V 

ADC.ATTN_2_5DB: napon punog 
raspona: 1.5 V 

ADC.ATTN_6DB: napon punog 
raspona: 2.0 V 

ADC.ATTN_11DB: napon punog 
raspona: 3.3 V 

Deklaracija raspona 
ulazne vrijednosti 
(zadano 12bit) 

pot.width(ADC.WIDTH_10BIT) 

ADC.WIDTH_9BIT: raspon 0 do 
511 

ADC.WIDTH_10BIT: raspon 0 do 
1023 

ADC.WIDTH_11BIT: raspon 0 do 
2047 

ADC.WIDTH_12BIT: raspon 0 do 
4095 

Očitavanje unosa value = pot.readl() 

value je cijeli broj od 0 do 

maksimuma raspona određenog 
naredbom ADC.WIDTH_#BIT 
(pogledajte prethodno) 

 

Varijabla vremena 

Pozivanje vrijednosti 
spavanja 

from time import sleep  

Korištenje funkcije 
spavanja 

sleep(sec) 
sec je broj sekundi za koje će 

program biti odgođen 

Pozivanje vrijednosti 
vremena 

import time  

Korištenje funkcije 
vremena 

current_time = time() 

The current_time varijabla će 

imati numeričku vrijednost jednaku 
broju sekundi od zadnjeg 
resetiranja na ploči 
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Struktura varijable ako (if) 

if <expr1>:  

     <statement1>  

elif <expr2>:  

     <statement2>  

elif <expr3>:  

     <statement3>  

     (...)  

else:  

     <statementn>  

<expr#>: kontrolni uvjet koji mora ispasti istinit ili lažan 

 

<statement#>: skup naredbi koje treba izvršiti kada je susjedni uvjet 
zadovoljen 

 

<expr#> (npr. skup <statement2> se izvršava kada je <expr2> zadovoljen) 

 

<statementn>: skup instrukcija koje se izvršavaju kada niti jedan od  
<expr#> uvjeta nije zadovoljen 

 

Struktura „while“ petlje 

while <expr>:  

   <statement(s)>  

<expr>: kontrolni uvjet koji mora ispasti istinit ili lažan 

<statement#>: skup naredbi koje treba izvršiti sve dok je <expr> uvjet 
zadovoljen 

 

Struktura „for“ petlje 

for <var> in <iterable>: 

     <statement(s)> 

<iterable>: kolekcija objekta, npr. 
popis koji sadrži  brojeve, 
alfanumeričke znakove itd. 

 

<var>: varijabla kojoj se dodjeljuje 
vrijednost sljedeće stavke u kolekciji 
<iterable>  

 

<stametement(s)>: skup instrukcija 
koje se izvršavaju pri svakoj iteraciji 

for <var> in range(<start>, <end>, <step>): 

     <statement(s)> 

range(<start>, <end>, <step>): 
funkcija koja vraća niz brojeva od  
<start> do <end>-1, s <step> razlikom 
između dva uzastopna broja (<start> i 
<step> parametri nisu obavezni). 

 

<var>: varijabla kojoj se dodjeljuje 
vrijednost sljedećeg elementa niza 
proizvedenog rasponom  
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<statement(s)>: skup instrukcija koje 
se izvode u svakoj iteraciji 

Razno 

DHT11 

import dht Uvoz DHT biblioteke 

sensor = dht.DHT11(Pin(pin_number)) 
Inicijalizacija varijable senzora s 
pripadajućim pin_number. 

sensor.measure() Ažuriranje vrijednosti senzora 

temp = sensor.temperature() 
Spremanje trenutne vrijednosti 
temperature 

hum = sensor.humidity() 
Spremanje trenutne vrijednosti 
vlažnosti 

OLED 
ZASLON 

from machine import I2C Uvoz I2C biblioteke 

import ssd1306 Uvoz ssd1306 biblioteke 

i2c = I2C(-1, scl=Pin(1), sda=Pin(0)) 
Inicijalizacija varijable i2c  na 
SCL & SDA iglama Pico-a 

oled_width = 128 

oled_height = 64 

oled = ssd1306.SSD1306_I2C(oled_width, 

oled_height, i2c) 

Inicijalizacija zaslona 

oled.text('Hello, World 1!', 0, 0) 

oled.text('Hello, World 2!', 0, 10) 

oled.text('Hello, World 3!', 0, 20) 

Pohranjivanje poruka u 
međuspremnik zaslona 

oled.show() 

Prikazivanje poruka (potrebno za 
prikaz poruka pohranjenih u 
međuspremniku zaslona) 

display.pixel(3, 4, 1) 

Postavite piksel koji je lociran na 
poziciji (x,y) na ekranu, s x=3 & 
y=4, na stanje 1 (tj. zaslon) 
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